解决 lispbox macOS 不兼容问题

误打误撞,解决了很重要的入门级问题,简要记录下.

lispbox 官网末尾说目前暂不兼容 10.4 以上系统:

TODO:

Compile on Mac OS X 10.4, for compatability
Make separate versions for common Linux distributions, and a statically compiled version

解决办法:

1. 下载 lispbox-0.7

2. 解压把 lispbox-0.7 放到应用程序目录,目录结构类似于: /Applications/lispbox-0.7

3. 修改 /Applications/lispbox-0.7/Emacs.app/Contents/MacOS/lispbox.sh 为:

1
2
3
4
5
6
7
8
#!/bin/bash
if [ "${0:0:2}" = "./" ]; then
export LISPBOX_HOME=/Applications/lispbox-0.7
else
export LISPBOX_HOME=/Applications/lispbox-0.7
fi
export SBCL_HOME=${LISPBOX_HOME}/sbcl-1.0.42/lib/sbcl
exec ${LISPBOX_HOME}/Emacs.app/Contents/MacOS/Emacs --no-init-file --no-site-file --eval='(progn (load "lispbox") (slime))'

4. 关闭 macOS 的软件来源限制,终端执行代码:

1
Sudo spctl --master-disable

5.双击打开 /Applications/lispbox-0.7/ 目录下的 Emacs,看到如图效果,即为成功:

lispbox效果

6.现在可以继续开启 macOS 的软件来源限制了,不会影响 Emacs 的了:

1
Sudo spctl --master-enable